CISCONETWORKING

Lista de comandos CISCO CCNA: Routing & Switching V5.0 – 3a Parte

comandos CISCO CCNA: Routing & Switching V5.0 – 3a Parte

298Vistas

Lista de comandos CISCO CCNA: Routing & Switching V5.0 – 3a Parte

 

COMANDO FUNCION

S1(config)# interface range f0/11-24

S1(config-if-range)# switchport mode access

S1(config-if-range)# switchport access vlan 10

S1(config-if-range)# end

Configurar un rango de interfaces como acceso y asociarlas a una VLAN.

S1(config)# interface f0/24

S1(config-if)# no switchport access vlan

S1(config-if)# end

Eliminar una asignación de VLAN.
S1(config)# no vlan 30 Eliminar una VLAN

S1(config)# interface f0/1

S1(config-if)# switchport mode dynamic desirable

Usar DTP (negociación) para iniciar un enlace troncal.

S1(config)# interface f0/1

S1(config-if)# switchport mode trunk

Configurar manualmente la interfaz como troncal
S2# show interfaces trunk Verificar la configuración de los enlaces troncales

S1(config)# interface f0/1

S1(config-if)# switchport trunk native vlan 99

Modificar la VLAN nativa. Esto se debe hacer en los dos extremos del enlace.

S1(config)# interface f0/1

S1(config-if)# switchport nonegotiate

Deshabilitar la negociación DTP en la interfaz.

S1(config)# interface f0/1

S1(config-if)# switchport trunk allowed vlan 10,99

Restringir las VLAN permitidas en un enlace troncal.
COMANDOS DE CONFIGURACIÓN BASICA DE ROUTER
Router# config terminal Ingresar al modo de configuración global
Router(config)# hostname R1 Asignar nombre al router
R1(config)# no ip domain-lookup Deshabilitar la búsqueda DNS
R1(config)# security passwords min-length 10 Establecer el requisito de largo de contraseñas
R1(config)# enable secret cisco12345 Asignar contraseña privilegiada protegida

R1(config)# line con 0

R1(config-line)# password ciscoconpass

R1(config-line)# exec-timeout 5 0

R1(config-line)# login

R1(config-line)# logging synchronous

R1(config-line)# exit

Asignar la contraseña a la consola.

Establecer un tiempo de espera por una sesión.

Evita que los logs o alertas corten el comando que se está ingresando.

R1(config)# line vty 0 4

R1(config-line)# password ciscovtypass

R1(config-line)# exec-timeout 5 0

R1(config-line)# login

R1(config-line)# logging synchronous

Asignar contraseña a las líneas VTY (TELNET, SSH).

Establecer un tiempo de espera por una sesión.

Evita que los logs o alertas corten el comando que se está ingresando.

R1(config)# service password-encryption Cifrar las contraseñas no protegidas
R1(config)# banner motd #INGRESO NO AUTORIZADO¡¡¡# Crear aviso de advertencia al que accede.

R1(config)# int g0/0

R1(config-if)# description Connection to PC-B

R1(config-if)# ip address 192.168.0.1 255.255.255.0

R1(config-if)# no shutdown

Describir y configurar una interfaz y luego activarla.

R1(config)# ip domain-name CCNA-lab.com

R1(config)# username admin privilege 15 secret adminpass1

R1(config)# line vty 0 4

R1(config-line)# transport input ssh

R1(config-line)# login local

R1(config-line)# exit

R1(config)# crypto key generate rsa modulus 1024

R1(config)# exit

Crear dominio.

Crear usuario con privilegios de enable

Habilitación de SSH en las líneas VTY

Autenticación local

Generar la clave RSA

COMANDOS DE DIRECCIONAMIENTO IPV6 ROUTER

R1(config)# interface g0/0

R1(config-if)# ipv6 address 2001:db8:acad:a::1/64

R1(config-if)# ipv6 address fe80::1 link-local

R1(config-if)# no shutdown

R1(config-if)# exit

R1(config)# ipv6 unicast-routing

Asignar IPv6 global a la interfaz

Asignar IPv6 de link local

Habilitar enrutamiento IPv6 unicast

R1#show ipv6 int brief Verificar direccionamiento IPv6 y estado de las interfaces
COMANDOS PARA ACCESO HTTP, HTTPS, CCP Y SDM
R1(config)# ip http server Habilita servicio http (puerto 80 de TCP)
R1(config)# ip http secure-server Habilita servicio https (puerto 443 de TCP)
R1(config)# username admin privilege 15 secret adminpass1 Crear usuario con privilegios de enable y contraseña protegida (MD5).
COMANDOS ENRUTAMIENTO ENTRE VLAN. ROUTE ON A STICK
R1(config)# interface g0/1.1 Creación de las subinterfaces

R1(config-subif)# encapsulation dot1Q 1

R1(config-subif)# ip address 192.168.1.1 255.255.255.0

Encapsulamiento de la subinterfaz, se asocia a la VLAN correspondiente con el número de la VLAN.

Asignación de IP a la subinterfaz

RUTAS ESTÁTICAS
R1(config)# ip route 192.168.1.0 255.255.255.0 10.1.1.2 Ruta estática con IP de router de siguiente salto
R3(config)# ip route 192.168.0.0 255.255.255.0 s0/0/0 Ruta estática con interfaz de salida
R1(config)# ip route 0.0.0.0 0.0.0.0 s0/0/1 Ruta por defecto con interfaz de salida
R1(config)# ip route 0.0.0.0 0.0.0.0 10.1.1.2 Ruta por defecto con IP de siguiente salto
R1(config)# ipv6 route 2001:DB8:ACAD:B::/64 serial 0/0/1 Ruta estática con interfaz de salida
R1(config)# ipv6 route 2001:DB8:ACAD:B::/64 FC00::2 Ruta estática con IP de router de siguiente salto
R1(config)# ipv6 route ::/0 serial 0/0/1 Ruta por defecto con interfaz de salida
R1(config)# ipv6 route ::/0 FC00::2 Ruta por defecto con IP de siguiente salto
ISP# show ipv6 route Verificar tabla de enrutamiento
BRANCH# show ipv6 interface brief Verificar interfaces por estado y configuración de IPv6
COMANDOS RIPV2 Y RIPNG

R1(config)# router rip

R1(config-router)# version 2

R1(config-router)# passive-interface g0/1

R1(config-router)# network 172.30.0.0

R1(config-router)# network 10.0.0.0

R1(config-router)# no auto-summary

R2(config-router)# default-information originate

Ingresar a la configuración RIP.

Cambiar a la versión 2.

Evita que actualizaciones RIP se envíen por esa interfaz

Declarar las redes directamente conectada.

Desactiva a sumarización automática

Redistribución de rutas por defecto

R1# show ip protocols Confirma el protocolo configurado
R2# debug ip rip Examinar actualizaciones RIP

R1(config)# ipv6 router rip Test1

R1(config)# interface g0/1

R1(config-if)# ipv6 rip Test1 enable

R1(config)# interface s0/0/0

R1(config-if)# ipv6 rip Test1 enable

Configuración de RIPng
R1# show ipv6 protocols Verificar el protocolo configurado.
R1# show ipv6 rip Test1 Verificar el proceso RIP configurado.

R2(config)# int s0/0/0

R2(config-if)# ipv6 rip Test2 default-information originate

Redistribución de una ruta por defecto dentro de la interfaz.

Deja un comentario