CISCONETWORKING

Como configurar HSRP en router CISCO

configuración HSRP

494Vistas

Información básica de configuración HSRP en un router Cisco:

Primeramente conoceremos que es HSRP

HSRP (Hot Standby Routing Protocol), es un protocolo propietario de Cisco que permite que dos o más routers trabajen juntos para representar una sola dirección IP para una red en particular. HSRP se considera un servicio de red de alta disponibilidad que permite la conmutación casi inmediata a una interfaz secundaria cuando la interfaz principal deja de estar disponible.

HSRP es un concepto bastante simple que funciona al tener un enrutador dentro de un grupo HSRP seleccionado como el enrutador primario o activo. El primario manejará todas las solicitudes de enrutamiento mientras que los otros enrutadores (backup o respaldo) dentro del grupo HSRP simplemente estarán en estado de espera o comúnmente llamado en modo standby. Estos enrutadores en espera permanecen listos para asumir toda la carga de tráfico si el enrutador principal deja de estar disponible. En este caso, HSRP proporciona alta disponibilidad de red ya que enruta el tráfico IP sin depender de un solo enrutador.

Primero lo primero.

Configuración básica de HSRP

Antes de analizar conceptos HSRP más avanzados, crearemos una configuración básica de HSRP para tener una idea de cómo funciona todo esto. Para este escenario, hemos publicado una imagen. Tenga en cuenta que uno o ambos de estos enrutadores podrían ser conmutadores multicapa (L3), como un 6509 o 3750 también y utilizar interface vlan. Pero para esta publicación vamos a referirnos a ellos como enrutadores.

R1 y R2 se configurarán y a la dirección virtual de HSRP se le asignará una dirección IP de 192.168.1.3/24. Todos los hosts en el segmento y en la VLAN usarán esta dirección como su puerta de enlace predeterminada.



Configurando R1

R1(config)# interface fastethernet0/17
R1(config-if)# ip address 192.168.1.1
R1(config-if)# standby 1 ip 192.168.1.3

 

Configurando R2

R2(config)# interface fastethernet0/19
R2(config-if)# ip address 192.168.1.2
R2(config-if)# standby 1 ip 192.168.1.3
Para que podamos ver el estado de HSRP y asegurarnos que HSRP esté funcionando usamos el comando “show standby” como se muestra a continuación

 

Ejecutamos el commando en R1

R1#show standby
FasthEthernet0/17 – Group 1
Local state is Standby, priority 100
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.776
Virtual IP address is 192.168.1.3 configured
Active router is 192.168.2., priority 100 expires in 9.568
Standby router is local:
1 state changes, last state change 00:00:22
Ejecutamos el commando en R2

R2#show standby
FasthEthernet0/19 – Group 1
Local state is Active, priority 100  // R2 activo
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 2.592
Virtual IP address is 192.168.1.3 configured
Active router is local
Standby router is 192.168.1.1 expires in 8.020
Virtual mac address is 0000.0c07.ac05
2 state changes, last state change 00:02:08

 

Podemos ver que R2 ha sido seleccionado como el router activo (Local state is Active”), el IP del enrutador virtual es 192.168.1.3 y R1 es el enrutador en estado de espera (“Local state is Standby”).

 



Cambiando enrutador como activo.

Como seleccionamos el enrutador como activo, esto lo hacemos cambiando la prioridad con el comando #standby 1 priority 101 le asignamos un mayor número de prioridad, ya que la prioridad por defecto es 100, asi que el enrutador con mayor prioridad será el que queda activo.

 

Usando nuestro ejemplo anterior, así es como se verían los comandos

—————————————————————–
R1(config)# interface fasthethernet0/17
R1(config-if)# ip address 192.168.1.1
R1(config-if)# standby 1 ip 192.168.1.3
R1(config-if)# standby 1 priority 101            // este comando hace que R1 sea activo
—————————————————————–
R2(config)# interface ethernet0
R2(config-if)# ip address 192.168.1.3
R2(config-if)# standby 1 ip 192.168.1.1
—————————————————————–

 

Escenario de fallas.

Supongamos que R1 falla, R2 quedaría como activo, pero que sucede si se restablece el servicio de R1, siempre R2 quedaría activo aun R1 tenga la prioridad mas alta.

Hay momentos en los que siempre se puede querer que R1 esté en un estado activo en el grupo HSRP. Cisco proporciona una forma de uso para controlar esto mediante el uso del comando “preempt”.

 

 

Preempt obliga a un enrutador a estar activo después de recuperarse de una falla.

Para realizar esta configuración lo haríamos de la siguiente manera.

 

R1(config)# interface fasthethernet0/17
R1(config-if)# ip address 192.168.1.1
R1(config-if)# standby 1 ip 192.168.1.3
R1(config-if)# standby 1 priority 150
R1(config-if)# standby 1 preempt<– esto hace a R1 volver al estado activo después de la falla
R2(config)# interface fasthethernet0/19
R2(config-if)# ip address 192.168.1.2
R2(config-if)# standby 1 ip 192.168.1.3
Configuración avanzada de HSRP – Equilibrio de carga
Ahora podemos ver qué tan bueno es HSRP y cómo nos permite tener una alta disponibilidad entre múltiples enrutadores para una sola red, pero prácticamente le estaríamos dejando la carga a un solo router, ya que los demás que están en modo de espera no están están operativos para el tráfico de información

 

Configurando balanceo de carga.

Podemos configurar HSRP para equilibrar la carga entre los enrutadores. Esto no nos ayuda con un único grupo HSRP, pero para múltiples grupos HSRP podemos distribuir la carga y hacer que cada grupo HSRP esté activo en diferentes enrutadores.

Al configurar múltiples grupos HSRP en una sola interfaz, se puede lograr el equilibrio de carga HSRP.

Así es como logramos esto.

——————————————————————–
R1(config)# interface fasthethernet0/17
R1(config-if)# ip address 192.168.1.1
R1(config-if)# standby 1 ip 192.168.1.3
R1(config-if)# standby 1 priority 150
R1(config-if)# standby 1 preempt
R1(config-if)# standby 1 name nework-one
!
R1(config)# interface fasthethernet1/17
R1(config-if)# ip address 10.1.1.1
R1(config-if)# standby 2 ip 10.1.1.3
R1(config-if)# standby 2 name nework-two
———————————————————————
R2(config)# interface fasthethernet0/19
R2(config-if)# ip address 192.168.1.2
R2(config-if)# standby 1 ip 192.168.1.3
R2(config-if)# standby 1 name nework-one
!
R2(config)# interface fasthethernet1/19
R2(config-if)# ip address 10.1.1.2
R2(config-if)# standby 2 ip 10.1.1.3
R2(config-if)# standby 2 priority 150
R2(config-if)# standby 2 preempt
R2(config-if)# standby 2 name nework-two
———————————————————————

En el ejemplo anterior, la fasthethernet0/17 del router 1 está activo para el grupo 1 y el enrutador 2 está en standby. La Fasthethernet0/19 del router 2 para el grupo 2 de HSRP está activo y el enrutador 1 está en standby. Esto nos permite tener cada enrutador trabajando para nosotros y reenviar paquetes para utilizar mejor nuestra inversión en nuestros equipos de red. También hemos agregado el comando de nombre de grupo HSRP para ayudar a describir mejor cada grupo de HSRP. Esto te puede ayudar cuando tienes varios grupos de HSRP que necesitas rastrear.

Deja un comentario